Main siteMain site  ForumForum  ForumSearch  Private messageEmail contact  RegisterRegister  Log inLog in 
Topic: OpenBCI Cyton gain setting not working
Reply to topic
Author Message
dmacd10



Joined: Aug 6, 2022
Posts: 2

PostPosted: Aug 6, 2022 10:43 PM    Post subject: OpenBCI Cyton gain setting not working

Hi there -

I'm trying to use my Cyton board with some electrodes that require the gain to be turned down...the default gain of 24x rails the sensors. I have designs working with the default gain, but if I change it at all, I get this:

F_OpenBCI ERROR: Received error from the device: Failure: Err: 9th char not X$$$Failure: Err: 9th char not X$$$Failure: too few chars$$$Failure: Err: 9th char not X$$$
Start error in element F_OpenBCI(1561): n: OpenBCI device start error

It looks like the command string being sent to board is not properly formatted.

I have worked around this so far by manually constructing a command string for the gain setting and setting it as the startup command, however this is less than ideal.

Would be great if the gain setting worked without extra logic - is it possible I'm doing something else wrong here?

Thanks,
Daniel
dmacd10



Joined: Aug 6, 2022
Posts: 2

PostPosted: Aug 7, 2022 12:04 AM    Post subject:

I spoke too soon...if I set my board up with the OpenBCI GUI and then forgo the reset command 'v' in the BioEra component, then I can get it to work.

I have not in fact succeeded at injecting custom startup commands to do gain setting. They either generate the same error or seem to be silently ignored.
jarek



Joined: Oct 22, 2007
Posts: 970

PostPosted: Aug 7, 2022 8:30 AM    Post subject:

Try to increase the "Command delay[ms]".

Try something much larger (like 100ms or even more) to see if it works. Later you may want to decrease it once you know the optimal value (in order to reduce the startup time).
Reply to topic